Back
Maintenance

Room server upgrade

Completed 24 Mar at 10:30am CET.

rooms.dividat.com
Completed

Maintenance completed

Posted 24 Mar at 10:30am CET.
Started

Pairing Play with Manager for assessments will be out of service during the server upgrade window.

Posted 24 Mar at 09:30am CET.